Page tree
Skip to end of metadata
Go to start of metadata

Plugin Prerequisites

The following requirements must be met in order to be able to use this plugin in your Jira instance:

JDK

A Sun JDK version 1.6 or higher, go to http://developers.sun.com/downloads/, and download the latest Java 6 JDK or an older Java 5 JDK, either will work but Java 6 is recommended.

Atlassian Jira

Atlassian Jira version 4.3.x or higher is required

Sonar

Any currently available Sonar distribution is compatible with this plugin

Download

The plugin distribution package is available from the JIRA Sonar Plugin Repository Directory.
After downloading the distribution package, you can install the plugin on JIRA.

JIRA Installation

Using the Universal Plugin Manager

The simplest way is to go to use the Universal Plugin Manager to install the plugin from the Atlassian Plugin Exchange. On the Install tab you can simply search for this plugin and install it, or Upload it using the Upload Plugin from either direct from our Nexus repository or from your own desktop.
After installation it is possible that you will be required to restart JIRA before the changes take affect.

By Hand

Save the downloaded *.jar file into the $JIRA_HOME/plugins/installed-plugins directory. You will then need to restart JIRA (many containers let you do this without restarting the container.)